Back to overview
Degraded
Rublon Admin Console not loading properly in North America
Mar 10 at 07:06pm CET
Affected services
Rublon Admin Console
Resolved
Mar 12 at 01:30pm CET
We have identified that the earlier issues with the Rublon Admin Console, affecting some users in North America, were due to AWS network problems in that region. We are pleased to inform you that these issues have been resolved, and the Admin Console is now fully operational.
Affected services
Rublon Admin Console
Created
Mar 10 at 07:06pm CET
We’re investigating an issue with the Rublon Admin Console that is impacting some users in North America. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services
Rublon Admin Console