Back to overview
Degraded

Email Delivery (Global) is down

Oct 9, 2025 at 6:21pm UTC
Affected services
Email Delivery (Global)

Resolved
Oct 10, 2025 at 7:16am UTC

Email Delivery recovered.

Created
Oct 9, 2025 at 6:21pm UTC

Email Delivery is degraded.