Back to overview
Degraded
Email Delivery (Global) is down
Jun 4, 2026 at 10:42pm UTC
Affected services
Email Delivery (Global)
Resolved
Jun 5, 2026 at 12:38am UTC
Email Delivery (Global) recovered.
Affected services
Created
Jun 4, 2026 at 10:42pm UTC
Email Delivery (Global) is degraded.
Affected services